Portnox 2025.10 Release Announcement from 2025-10-12 23:00 CDT to 2025-10-13 02:00 CDT

Scheduled maintenance America AgentP Enrollment Services Alerting Services API Authentication Services Authentication Services (Captive Portal) Authentication Services (RADIUS) Multi Factor Authentication Services Azure infrastructure CASB Servics Certificate Services CRL Services OCSP Services SCEP Services Change of Authorization (CoA) Services Directory Synchronization Services Integration Services Absolute Secure Endpoint Integration Services CrowdStrike Integration Services Jamf Integration Services Microsoft Intune Integration Services SentinelOne Integration Services IoT Fingerprinting Services Logging SiEM Services AAA Logging Services Portal MAC Address Onboarding Portal Self Onboarding Portal Administration Portal TACACS+ Services ZTNA Services Europe AgentP Enrollment Services Alerting Services API Authentication Services Multi Factor Authentication Services Authentication Services (RADIUS) Authentication Services (Captive Portal) Azure infrastructure CASB Services Certificate Services CRL Services OCSP Services SCEP Services Change of Authorization (CoA) Services Directory Synchronization Services Integration Services Absolute Secure Endpoint Integration Services CrowdStrike Integration Services Jamf Integration Services Microsoft Intune Integration Services SentinelOne Integration Services IoT Fingerprinting Services Logging AAA Logging Services SiEM Services Portal Self Onboarding Portal Administration Portal MAC Address Onboarding Portal TACACS+ Services ZTNA Services
2025-10-12 23:00 CDT · 3 hours

Updates

Scheduled

Updated Portnox 2025.10 Release Announcement

Scheduled Maintenance Notification

Date/Time Stamp: Sunday, October 12th, around 11 PM CDT

Details:

In our ongoing commitment to providing outstanding service, we will perform a scheduled upgrade to 2025.10.

Start Time: Sunday, October 12th, around 11 PM CDT
Expected Completion: Monday, October 13th, around 2 AM CDT

Impact:
No downtime or interruption in service is expected during this process.

What’s Included:

  • Subscription Plan Corrections
    Fixed issues related to inaccurate license counts shown on the Subscription page in Portnox Cloud. Customers should now see corrected and consistent license usage data.
  • Expanded Help Center Documentation
    Added new vendor-specific guides and resources accessible from the Help page within the Portnox Cloud portal to assist with integrations and deployment scenarios.
  • Streamlined Self-Onboarding Experience
    Introduced multiple UI enhancements to make self-onboarding more intuitive. This includes the new ability to onboard ChromeOS devices via the self-service workflow.
  • Enhanced Audit Event Logging
    Added new audit events that provide better visibility into device deactivation actions within Portnox Cloud, improving compliance tracking and incident reviews.
  • Improved Guest Authentication Reporting
    Exported guest data now includes the SMS phone number used during guest registration, giving administrators more complete records of access attempts.
  • Added Custom SAML Attribute Policies
    Portnox Cloud administrators can define custom SAML attributes to include additional user information in the SSO process. These attributes are passed to the target ZTNA SSO Web Resource and can, for example, determine which Group Policy should be applied to the user when connecting to VPN.
  • ZTNA SSO Certificate Expiration Notifications
    Introduced proactive alerts for ZTNA SSO application certificates. Administrators will now receive notifications 30 days and 48 hours before certificate expiration, as well as an alert for expired certificates, enabling timely action to prevent service disruptions for end users.

Historical Release Notes can be found here: https://www.portnox.com/status/

September 29, 2025 · 11:26 CDT

← Back